Anvil Game Studios

Author Topic: Can't fire my guns  (Read 718 times)

0 Members and 1 Guest are viewing this topic.

Offline hot_pocket3

  • Landsman
  • *
  • Posts: 4
Can't fire my guns
« on: March 18, 2018, 04:29:55 am »
For some reason, im stuck in melee mode. WHen i press x i can go to rifle mode and when i right click i can aim. BUt when i left click i go back into melee mode.

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 539
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Can't fire my guns
« Reply #1 on: March 18, 2018, 04:45:53 am »
hot_pocket3,

Have you changed any keybindings before?

You might have changed one of them unintentionally. Verify your bindings, this might fix the issue.

If that doesn't work give this a shot:

1. Uninstall Holdfast

2. Delete this folder: C:\Users\Your Username\AppData\LocalLow\Anvil Game Studio

3. Reinstall

If the issue continues after this:

Make the glitch happen again, then press F2 and take a screenshot of the log - you may have an error in the log.

edit: also, you should know that if you fire without aiming in Holdfast you go into melee. This isn't what you're experiencing, right?
« Last Edit: March 18, 2018, 04:48:54 am by Jean-Baptiste »

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 539
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Can't fire my guns
« Reply #2 on: March 18, 2018, 04:57:39 am »
Game Tip 2 - Left Clicking When Using A Musket From Firing Mode Is Going Into Melee Mode
Within the game, you right click to aim, left click to fire and press 'R' to reload. If you left click when you're in firing mode with a bayonetted musket, it will go automatically into melee mode. You can disable this through the game options.

- Follow the below instructions:
1) Go to 'Settings' > Then 'Game' > Look under 'Melee Combat' > And disable 'Auto Bayonet Switch'.

Also, just to verify: you said you already did this?

Offline hot_pocket3

  • Landsman
  • *
  • Posts: 4
Re: Can't fire my guns
« Reply #3 on: March 18, 2018, 05:04:18 am »
Yes, i already tried their suggestions. I don't go into melee mode anymore, but i also still cant fire my gun at all.

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 539
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Can't fire my guns
« Reply #4 on: March 18, 2018, 05:11:48 am »
Yes, i already tried their suggestions. I don't go into melee mode anymore, but i also still cant fire my gun at all.

Check your keybindings, then do my second suggestion. It will totally reset your game settings and hopefully fix the bug.

Offline hot_pocket3

  • Landsman
  • *
  • Posts: 4
Re: Can't fire my guns
« Reply #5 on: March 18, 2018, 07:27:33 am »
i checked my keybindings and they all seem normal. I uninstalled and reinstalled the game but nothing seems to working.

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 539
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Can't fire my guns
« Reply #6 on: March 18, 2018, 01:04:00 pm »
Did you complete this step:

Delete this folder: C:\Users\Your Username\AppData\LocalLow\Anvil Game Studio

?

« Last Edit: March 18, 2018, 01:06:31 pm by Jean-Baptiste »

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 539
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Can't fire my guns
« Reply #7 on: March 19, 2018, 08:31:24 pm »
Any luck with this? Let me know and I can keep trying to think of fixes.

Offline Karl Marx

  • Landsman
  • *
  • Posts: 2
Re: Can't fire my guns
« Reply #8 on: April 14, 2019, 03:40:17 am »
I experienced the same bug. The bug came suddenly and I tried almost everything to fix it without results.
At last, I tried changing my firing-key to another button (I used "middle key") and that worked like a charm. I didn't have this problem earlier. But apparently, my game insists I have melee and firing attack be two different keys