Anvil Game Studios

Author Topic: Weird crashing on startup  (Read 157 times)

0 Members and 1 Guest are viewing this topic.

Offline helpme

  • Landsman
  • *
  • Posts: 4
Weird crashing on startup
« on: April 14, 2018, 02:43:28 am »
The game was running fine until recently when I did a update for the game and suddenly whenever I would launch the game it would go to the main menu fine, I could even use the settings, multiplayer menu, and hell even log into a game, however, from the second I launched there was a window that would appear stating the game crashed all the while I'm able to do all this, and upon entering a game and trying to spawn the game would crash with a application not responding error, although interestingly enough this only happens if there's a significant portion of players online (30-40 plus) and it'll run fine despite the error box in the background. I have tried every troubleshooting step and recently reinstalled my OS for some unrelated reasons, and it still did not work. It does this very same thing each and every time I launch the game, and I'm at my wits end, below is my output_log, error log, crash.dmp, and my dxdiag.

AGAIN, I'VE ALREADY TRIED ALL OF THE TROUBLESHOOTING STEPS, DISABLING ANTIVIRUS, RUNNING AS ADMINISTRATOR, MESSING WITH GRAPHICS, SETTING LAUNCHER OPTIONS


Below is a selection of GIFS describing what I mean, since the concept is a bit odd, what your seeing is me launching the game, demonstrating the error box that appears, and me still being able to use menus and even log into a game, and then towards the end where I bring the box back up and hit "OK" and the game closes.

https://gyazo.com/787de8f20d78e8191ac83f3dc3b9c5ef
https://gyazo.com/c369b8af07b04f5b8aaf8a77acd94558
https://gyazo.com/0795765502a495ee69684348f6690007
https://gyazo.com/ba1cd75901b2447718a9f6efc52107bf



I've viewed some of the other topics on similar crashing issues but I feel mine is unique in I was able to launch the game fine before a certain update with this very same computer, and in addition, I can still operate the game right up until trying to spawn in.

I had also not updated the computer at all from the point it was working before to the point it wasn't working anymore, so I do not believe Windows Update is the problem.

I do not use any performance monitoring programs at all(Riva Tuner,MSI Afterburner, etc.).

I have AVG and Anti-Malwarebytes as Anti-virus/Anti-malware.

From the details from your steam page on your minimum requirements, I should only ever be experiencing issues once I'm in a game, according to that note at the bottom about the graphics card, not displaying a crash error when I launch the game, not to mention I already play the game on the lowest graphical settings.


"MINIMUM:
OS: Windows 7 64-bit, Windows 8 64-bit or Windows 10 64-bit
Processor: 2 GHz Dual Core
Memory: 4 GB RAM
Graphics: Direct X 11 Compatible Card
DirectX: Version 11
Network: Broadband Internet connection
Storage: 8 GB available space
Additional Notes: An Intel® HD Graphics 4000 card is capable of running the game at a low framerate when playing Army based game modes on minimum graphics settings."


In case there was any information missing below I'll list off MY system specifications in basic here:

Windows 10 Home 64-bit
2 TB hard drive
12 GB of RAM
i5-4460 Quad CPU with Direct X 11/12
Intel HD Graphics 4600 GPU



Error log
Spoiler
[close]

output_log
Spoiler
[close]

dxdiag
Spoiler
[close]


crash.dmp download link
https://drive.google.com/file/d/1K550Uz_q4kjYrT9t0olSqZhPMTau2jtl/view
« Last Edit: April 14, 2018, 08:44:05 am by helpme »

Offline Blaze

  • Server Administrator
  • Master's Mate
  • *
  • Posts: 875
  • Faction: British Empire
Re: Weird crashing on startup
« Reply #1 on: April 17, 2018, 07:24:05 pm »
Hello, Helpme.

Have you tried Verifying game cache?

Offline helpme

  • Landsman
  • *
  • Posts: 4
Re: Weird crashing on startup
« Reply #2 on: April 18, 2018, 12:46:03 am »
Yes I have, several times, and there has been no change to the result, it still does the exact same issue as described above.
« Last Edit: April 18, 2018, 12:53:45 am by helpme »

Offline Blaze

  • Server Administrator
  • Master's Mate
  • *
  • Posts: 875
  • Faction: British Empire
Re: Weird crashing on startup
« Reply #3 on: April 21, 2018, 01:17:05 pm »
I would recommend you re-install the game, but before running it VERIFY the game cache, then run it.

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 565
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Weird crashing on startup
« Reply #4 on: April 25, 2018, 07:09:19 pm »
Any progress on this issue?

Offline helpme

  • Landsman
  • *
  • Posts: 4
Re: Weird crashing on startup
« Reply #5 on: April 29, 2018, 08:44:04 pm »
I have reinstalled the game and followed your instructions to the point, there has been no change and the game is still experiencing the same errors as talked about originally.

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 565
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Weird crashing on startup
« Reply #6 on: May 01, 2018, 07:29:44 pm »
igdusc64.dll is specifically related to your graphics drivers. There is a chance that your integrated graphics just can't run the game. However, when I Googled the error it seems that a fair number of Unity developers are encountering this issue in the last few months.

I'm not much of a game dev, so I can't offer much more advice.

I saw a few people saying Avast or Afterburner might contribute to this issue - but I wouldn't think so. And you have already addressed this stuff.

Make sure your graphics drivers are up to date. You may even have to uninstall and reinstall your drivers, just in case that igdusc64.dll is corrupted or something. It's possible that a change in the Unity engine is causing this as well, since other Unity users are experiencing it.

Offline Jean-Baptiste

  • Regiment Leaders
  • Chaplain
  • *
  • Posts: 565
  • 89e COL | AGS/HCL Admin
  • Faction: French Empire
Re: Weird crashing on startup
« Reply #7 on: May 01, 2018, 11:35:47 pm »
Upon further research this appears to be an issue with Unity 5.6, I'm not sure AGS can fix it directly.

I believe they are currently upgrading the engine, so that may solve your issue.

Offline helpme

  • Landsman
  • *
  • Posts: 4
Re: Weird crashing on startup
« Reply #8 on: May 02, 2018, 08:59:54 pm »
I've already uninstalled and reinstalled my graphics driver and updated it, but if its an issue with Unity itself then I suppose all I can do is wait, thanks for the information.